[Resolved] 2-step verification causes problem


Home Forums Synology Alarm Clock 2-step verification causes problem

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1265
    officer.young
    Participant

    My DSM User account fails to set up Account Settings, with “Authorisation error”

    Settings can not be changed, no Serial number shows.

    2-Step Verification is enabled.

    If disabled, Setup works OK

    I want 2-Step verification with my accounts.

    Is something wrong?

    Is there a fix?

    #1267
    Sergei Parfenov
    Keymaster

    Hello.
    Two step verification can’t be used for AlarmClock account, because it should do login automatically by schedule, and the second step of verification cannot be done automatically.
    But you could (and this is the right way) to create special account for AlarmClock,
    * with admin privileges,
    * without any other permissions. (only permission for AudioStation and larmClock apps should be turn on)
    And turn off 2-factor auth for this account.
    So you still use you account with 2-factor auth to login into DSM, and AlarmClock uses internally its special account with minimal acess rights.

    #1272
    officer.young
    Participant

    Thanks for your quick reply.

    I’ve done this approach and it works fine, just seems a little bit of a ‘kludge’ workaround, but it seems no other way possible from your explanation, so it’ll do.

    Cheers

    #2543
    Ladislav
    Participant

    I used the two-step verification of the admin account. The alarm clock no longer works.

    Not some solution?

    #2545
    Sergei Parfenov
    Keymaster

    Hello.
    I’m sorry, AlarmClock can not work with two-step auth.
    You could create another account with very restricted admin permissions and use it for AlarmClock.
    See http://www.nasalarmclock.com/synology/description/mainsettings/

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.